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DPA 5 Troubleshooting and OEM Application Configuration Manual 
 
 
The complete DPA 5 User Manual can be found at: 

 
Start ► All Programs ► Dearborn Group Products ► DPA 5 ► Documentation ► DPA 5 User Manual 

 
 
Permission is granted to copy any or all portions of this manual, provided that such copies are for use with the DPA 5 product and that “© 2010-2014 Dearborn Group, Inc.”, 
(herein referred to as “Dearborn Group”, “DG Technologies”, or “DG”), remains on all copies. 
 
 
DPA® and the DG® logo are registered trademarks of Dearborn Group, Inc.  TruckConnect® and CarConnect® are registered trademarks of Dearborn Group, Inc.   
 
 
Other products that may be referenced in this manual are trademarks of their respective manufacturers. 
 
 
The DPA Product line and products supporting the DPA have been awarded the following U.S. Patents: 
 
 
 

Patent # Date Patent Overview 

6,772,248 08-03-04 Protocol adapter for in-vehicle networks. 

7,152,133 12-19-06 Expanded functionality protocol adapter for in-vehicle networks. 

7,337,245 02-26-08 Passing diagnostic messages between a vehicle network and a computer. 

7,725,630 05-25-10 Passing diagnostic messages between a vehicle network and a computer using J1939 or J1708. 

8,032,668 10-04-11 Passing diagnostic messages between a vehicle network and a computer using J1939 or J1708. 

8,152,557 04-10-12 Positive locking mechanism for USB connected devices. 

7,984,225  07-19-11 ASCII gateway to in-vehicle networks. 

7,660,934  02-0910 ASCII gateway to in-vehicle networks. 
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2.   Ensuring Your DPA 5 Drivers Are Up-To-Date 

The most important aspect of troubleshooting is to ensure that the drivers for the DPA 5 are up-to-date.  Before attempting to perform troubleshooting, please connect to the 
Internet and run DG Update. 
 

Start ► All Programs ► Dearborn Group Products ► DPA 5 ► DG Update 
 

 

Click the Check For Updates button.  If your drivers 
are not up-to-date (red), click the Download button that 
will appear.  When prompted to download, click the Yes 
button and after the download is complete, the install 
will start automatically. 
 
Connect to a vehicle and run AVT (Chapter 3).  If you 
are prompted that there is new firmware available, click 
the OK button.  DO NOT INTERRUPT POWER TO 
THE DPA 5 even if it appears to be stalled at about 
60%.  It can appear stalled for about 2-3 minutes, but it 
will eventually finish. 
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3.   Troubleshooting Vehicles Using Adapter Validation Tool (AVT) 

If your application is having trouble using the DPA 5 after following the instructions for configuring that application, you can use the DG Adapter Validation Tool (AVT) to 
troubleshoot the DPA and validate that: 
 

1. The DPA 5 drivers are installed properly. 

2. The PC can communicate with the DPA 5. 

3. The DPA 5 can see messages on the vehicle data bus. 

3.1. Before Starting the Troubleshooting Process 
 

 Ensure the vehicle cable is securely attached (fully screwed in) to the DPA 5. 

 Ensure the USB cable is securely attached (fully screwed in) to the DPA 5. 

 Ensure your vehicle ignition switch is in the “Run” position. 

 Unplug your DPA 5 from the vehicle for 15 seconds.   

 Plug the DPA 5 back into the vehicle and ensure Power LED is lit. 

o If the Power or To PC LED is flashing, the DPA 5 is stuck in bootloader mode from a failed firmware update.  See the chapter on manually 
updating the firmware in the DPA 5 User Manual. 

 Unplug your DPA 5 USB cable from the PC. 

 Reboot your PC and let the PC settle down after logging on. 

 Reconnect DPA 5 USB cable to the PC. 

 Listen for the familiar da-ding “USB device found” sound.   
o If you cannot hear this sound, the PC cannot communicate with the DPA 5 and AVT will not be successful.  Try other USB ports until you hear 

that sound.  DG’s Technical Support department has seen PCs where one or more USB ports have been defective, but others are fully 
operational. 

o If the Windows™ New Hardware Wizard appears, complete the process.  DO NOT CANCEL THE WIZARD or the DPA 5 will not work. 
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Troubleshooting can now begin by running “Adapter Validation Tool” from the icon on the desktop or at: 
 

Start ► Programs ► Dearborn Group Products ► DPA 5 ► Adapter Validation Tool 
 

 
 
Press the correct button to select which vehicle type you will be troubleshooting.  The following two chapters discuss Medium/Heavy-Duty (MD/HD) and Light/Medium-Duty 
(OBDII) troubleshooting.   
 

For the 2013 (and newer) Volvo chassis with Volvo engine, Chapter 6 is  
dedicated to using AVT to diagnose connections to this vehicle platform. 
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4.     Medium/Heavy-Duty (MD/HD) Troubleshooting with AVT 

 

Select the following: 

Vendor  DGDPA5MA - Dearborn Group DPA 5 Multiple Application 

Device  1 – DG DPA 5 Dual-CAN USB – USB 

Protocol  J1708 or J1939 (see below) 

 

  
J1708 Connector 
(6-pin Deutsch) 

J1939 Connector 
(9-pin Deutsch) 

This connector only has 
J1708/J1587. 

This connector typically has  
J1939 and J1708/J1587. 

 
Click the Run Test button. 

 
Depending on the results, both the RP1210 Status Window and RP1210 Data Message Window will turn green (pass) or red (fail). 

If you see data in the RP1210 Data Message Window, your DPA 5 is installed and is functioning properly!  Skip forward to the chapter on how to configure your OEM 
application to use the DPA 5. 

4.1.   Test Results Discussion Dialog Box 
After the test, read the Test Results Discussion and Next Steps screen very carefully and follow those directions to help diagnose where the issue may be.  If, 
after reading and following those instructions, you cannot get the DPA 5 working, please contact DG technical support. 

4.2.   AVT Test Outcomes 
 If both the RP1210 Status Window and RP1210 Data Message Window turn green then the DPA 5 is working.  You need to read how to configure your OEM 

application to use the DPA 5 later in this document.  There is no need to call DG until you have followed the instructions on configuring your OEM application to 
use the DPA 5. 

 If the RP1210 Status Window turns red, then there is a problem causing the PC not to communicate with the DPA 5.  This may be something as simple as 
having power to the DPA 5 or a USB issue with the PC.  Disconnect the DPA from the vehicle and PC; reboot the PC; reconnect the DPA 5 to the vehicle and 
PC, but this time connecting to another USB port. 

 If the RP1210 Status Window turns green and the RP1210 Data Message Window turns red, then the PC is seeing the DPA 5, but not seeing messages 
from the data bus.  Check the vehicle ignition switch; change the protocol setting and retest.   
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5.   Light/Medium-Duty (OBDII) Troubleshooting with JVT 

The DPA 5 supports all OBDII protocols except J1850 PWM.  This protocol was prominent on Ford vehicles prior to 2004-2005 when Ford switched to ISO15765 
(a CAN-based protocol). 
 

 

Select the following: 
 

 Device   DPA 5 – Dearborn Group, Inc. 
 Protocol OBDII 

 
Click the Run Test button.   

 
Depending on the results of the test, both the J2534 Status Window and J2534 Data Message Window will turn green (pass) or red (fail).  The JVT test outcomes are the 
same as the AVT tool (above).  If after following the Test Results Discussion and Next Steps screen, you cannot get the DPA 5 to read data, contact DG technical 
support.



6.   Troubleshooting Volvo/Mack 2013 (and Newer Vehicles)

 
NOTE:  This section applies to the 2013 and newer Volvo/Mack chassis with Volvo engines and does not apply to the Volvo/Mack chassis with a Cummins engine. 
 
Beginning in 2013, Volvo introduced a new diagnostic connector for a Volvo/Mack chassis with a Volvo engine.  It is based “in part” on the SAE standard J1962 (OBDII) 
connector.  It has two separate CAN channels with ISO15765 on CAN Channel 1 and J1939 on CAN channel 2.  It also has J1708/J1587.   
 
Since a second CAN channel and a J1708 channel that are not part of the J1962 OBDII standard, this has required every diagnostic adapter vendor to develop a new cable 
(or set of cables) for this specific platform.  
 
The next sections discuss the special cables created for this platform, and how to troubleshoot the DPA 5 interaction with this platform.  
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6.1.   Use the DG-DPA5-9OBDII-CABLE for Troubleshooting 

 
Connect this cable to the OBDII connector on the vehicle. 
 

 This cable only works for Volvo PTT, DG Diagnostics (OBDII), or third-party applications like PocketFleet Diagnostics.  A user cannot connect to a 
component application like Allison, Eaton, Meritor-WABCO, or Bendix through this cable!!!   

 If you want to run component applications like Allison, Eaton, Meritor-WABCO, you will need to add the DG-V130XOVER-CABLE (see below). 

 

6.2.  Using AVT to Test This Vehicle Platform – J1708 Protocol 
1. Connect the DG-DPA5-9OBDII-CABLE to the DPA 5 and the vehicle OBDII connector. 
2. Run AVT. 
3. Select 

i. Vendor:    DGDPA5MA - Dearborn Group DPA 5 Multi Application 
ii. Device:    1 – DG DPA 5 Dual-CAN (MA) USB – USB 
iii. Protocol:  J1708 

4. Press the Run Test button. 

6.3. Using AVT to Test This Vehicle Platform – ISO15765 
1. Connect the DG-DPA5-9OBDII-CABLE to the DPA 5 and the vehicle OBDII connector. 
2. Run AVT. 
3. Select 

i. Vendor:   DGDPA5MA - Dearborn Group DPA 5 Multi Application 
ii. Device:   1 – DG DPA 5 Dual-CAN (MA) USB – USB 
iii. Protocol:  ISO15765 

4. Press the Run Test button. 
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6.4. Using AVT to Test This Vehicle Platform – J1939 
1. Connect the DG-DPA5-9OBDII-CABLE to the DPA 5 and the vehicle OBDII connector. 
2. Run AVT. 
3. Press the Advanced Test button to get the Advanced Test dialog box. 
4. Select 

i. Vendor:   DGDPA5MA - Dearborn Group DPA 5 Multi Application 
ii. Device:   1 – DG DPA 5 Dual-CAN (MA) USB – USB 
iii. Protocol:   J1939 
iv. Baud Rate: 250 

1. Check Use Baud Rate checkbox. 
v. Channel: 2 

1. Check Use Channel checkbox. 
5. Press the Run Test button. 

6.5.   Using the J2534 Validation Tool (JVT) to Test This Vehicle Platform – ISO15765 
1. Connect the DG-DPA5-9OBDII-CABLE to the DPA 5 and the vehicle OBDII connector. 
2. Run JVT. 
3. Select 

i. Device:   DPA 5 – Dearborn Group, Inc. 
ii. Protocol:   ISO15765 

4. Press the Run Test button. 



DPA 5 Troubleshooting and OEM Application Configuration Manual 

 
Page 12 of 21 © 2014 Dearborn Group, Inc. 

 

7.    Setting Up RP1210-Compliant Applications 

The DPA 5 works with all RP1210 (A, B, C) compliant applications that use J1708/J1587, CAN/J1939, J1850 VPW (GM Class II), and the ISO15765 protocols.  This section 
shows how to configure the most common applications to work with the DPA 5 in USB mode.  
 
Selecting an RP1210 adapter varies widely, however terminology remains pretty much the same: 
 

If You See These Terms Select This 

Vendor, API, DLL, Manufacturer 
Dearborn Group DPA 5 Multiple Application 
Or  
DGDPA5MA 

Device Name, Adapter Name DG DPA 5 Dual-CAN (MA) USB, USB 
Device, DeviceID 1 

Protocol  

Most Commonly Encountered: 
 J1708 (J1708/J1587) 
 J1939  
 ISO15765 
 CAN 

7.1.   Allison DOC 
1. Start program. 
2. Click Connect to Vehicle. 
3. Select the Correct Transmission Type. 
4. Uncheck Smart Connect. 
5. Click Connect. 
6. Click Advanced Setup. 
7. Select vendor of Dearborn Group DPA 5 Multiple Application. 
8. Select protocol of J1939 or J1708. 
9. Select correct device of DPA 5 Dual CAN USB. 
10. Click OK. 
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7.2.   Bendix ABS Diagnostics 
NOTE:  DO NOT RUN Bendix ABS Diagnostics until you have done the following: 

 
1. Start program.   
2. If Diagnostic Interface Selection dialog box does not appear, click on Vehicle Interface Adapter icon. 

a. Select RP1210A Device Using J1708 Line:  DPA 5 Dual CAN USB.  
3. Click OK. 

7.3.   Caterpillar Electronic Technician (ET) 
1. Start Program. 
2. Click Utilities ► Preferences ► Communications from the menu bar. 
3. Click on Communication Interface Device dropdown box. 
4. Select RP1210 Compliant Device. 
5. Click Advanced 
6. Select DPA 5 Dual CAN USB in the RP1210 Communication Adapter Device box. 
7. Click OK 
8. Check Enable Dual Data Link Service 
9. Click OK. 
 
CAT ET Notes:   

 Enable Dual Data Link.  This checkbox should be “checked” in most cases.  However, on some older J1708 (ATA) only vehicles, ET will not work with this 
checkbox checked.  If ET does not connect, try “un-checking”, or “checking” this button. 

o The DPA 5 does not support the CAT Data Link (CDL) protocol common among CAT off-highway vehicles and industrial stationary equipment.  
CDL is a proprietary protocol requiring a CAT Communications Adapter. 
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7.4.   Cummins INSITE 
1. Start Program. 
2. Click on File ► Connections ► Add New Connection. 
3. Click Next. 
4. Click radio button for RP1210 Adapters and click Next. 
5. Select correct vendor, device, and protocol: 

a. Dearborn Group DPA 5 Multiple Application 
b. DG DPA 5 Dual-CAN USB 
c. Auto Detect. 

i. If you are on an older vehicle and it does not connect, choose J1708. 
6. Click Next and a Connection Name screen appears. 
7. Click Next and a screen prompts you to indicate whether you want to make this connection active or set up another connection. 
8. Click on make this connection active. 
9. Click Finish. 

7.5.   Detroit Diesel Diagnostic Link V7 

7.5.1. From Windows Start Menu 

1. Start ► Programs ► Detroit Diesel ► Diagnostic Link ► SID configure 
2. Select DPA 5 Dual CAN USB. 
3. Click OK. 

7.5.2. From Inside DDDL 

1. Tools ► Options ► Connections Tab ► SID Configure. 
2. Select DPA 5 Dual CAN USB. 
3. Click OK. 
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7.6.   Detroit Diesel Diagnostic Link V6.47 
There are two ways to open v6.47, depending on your installation. 
 
B. If you have the Detroit Diesel Electronic Tool Suite on your desktop: 

 
1. Select Detroit Diesel Electronic Tool Suite icon from desktop. 
2. Select Configure button. 
3. Select DG DPA 5 Dual-CAN (MA) USB, USB, select OK button. 
4. Select Refresh button. 
5. Click on highlighted DDDL 6 item. 
6. Select Look at active and inactive faults. 

 
B.  If you have the Diagnostic Link icon on your desktop: 
 

1. Select Diagnostic Link icon from desktop. 
2. Select Look at active and inactive faults. 
3. To change the adapter, select Tools | Options | Interface 
4. Select DG DPA 5 Dual-CAN (MA) USB, USB from Local Communication Interface drop-down list. 
5. Select OK button. 

7.7.   Dana Diagnostic Tool 2.x.x 
1. Start program 
2. Under Adapter Selection, choose Dearborn Group DPA 5 Multi Application:DG DPA 5 Dual CAN (MA) USB, USB 
3. Select Connect J1708 or Connect J1939 or Connect PLC as appropriate for your controller. 

7.8.   Eaton ServiceRanger 3.x 
1. Start Program 
2. Click Tools ► Settings ► Connection. 
3. Under Driver choose Dearborn Group DPA 5 Multiple Application  
4. Select DPA 5 Dual CAN USB for both the J1708 and J1939 device. 
5. Click OK. 
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7.9.   Freightliner ServiceLink (Including Cascadia) 
1. Start program. 
2. From the top menu bar, choose Admin. 
3. Click on Show All Devices. 
4. Vendor   =  Dearborn Group DPA 5 Multiple Application 
5. J1708 Device =  DG DPA 5 Dual-CAN (MA) USB, USB 
6. J1939 Device =  DG DPA 5 Dual-CAN (MA) USB, USB 
7. CAN Device 

a. Click Configure 
b. Select DG DPA 5 Dual-CAN (MA) USB, USB 

8. Click Save Settings. 

7.10. International Truck and Engine 

7.10.1. Master Diagnostics (MD Fleet) 

1. Start program. 
2. Choose File ►  MD Settings►   COM Device ►  Window with general VDA selection 
3. Select Dearborn Group DPA 5 Multiple Application ► Window with specific port DPA 5 Dual CAN USB.  

7.10.2. Navistar Hydraulic ABS 

1. Start program. 
2. Choose File ► Hydraulic ABS Settings ► COM Device ► Window with general VDA selection 
3. Select Dearborn Group DPA 5 Multiple Application ► Window with specific port DPA 5 Dual CAN USB. 

7.10.3. Navistar IPC 

1. Start program. 
2. Choose File ► Settings ► COM Device ► Window with general VDA selection 
3. Select Dearborn Group DPA 5 Multiple Application ► Window with specific port DPA 5 Dual CAN USB. 
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7.10.4. Diamond Logic Builder (DLB) 

1. Start program. 
2. Choose Tools► Select Com Link ► Listing of adapters  
3. Select Dearborn Group DPA 5 Multiple Application ►  Listing of ports DPA 5 Dual CAN USB. 

7.10.5. Service Assistant (The new MD Fleet) 

1. Start program. 
2. Press third button from the top along the left side (has an icon that looks like a miniature interface cable.) 

a. A window comes up that says Communication Device Selection and has two drop down boxes.   
b. Select Dearborn Group DPA 5 Multiple Application ►  DPA 5 Dual CAN USB. 

7.10.6. ServiceMaxx: 

1. Select ServiceMaxx icon from desktop 
2. Enter username and password (if required) 
3. Select Tools ► Select COM Link ► Dearborn Group DPA 5 Multiple Application ► DG DPA 5 Dual-CAN (MA) USB, USB ► select J1708 or J1939 

depending on engine type. 
4. "Searching for Engine" appears 
5. Select engine type when prompted and click OK button. 

7.11.   Meritor-WABCO Toolbox 
1. Start Program. 
2. Click System Setup; then select COM Port. 
3. Select Dearborn Group DPA 5 Multiple Application; the protocol to use is J1939 or J1708. 
4. Select DPA 5 Dual CAN USB and click OK. 
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7.12. Volvo/Mack VCADS Pro 

7.12.1. From Initial VCADS Setup  

1. When prompted to configure a Communication Unit select RP1210A adapter. 
2. When prompted for the adapter, select DPA 5 Dual CAN USB. 
3. Select USB for the Port. 
4. Select J1708 for the protocol. 
5. When prompted for the Electrical Systems. 

a. Click Volvo Trucks – VERSION2 and select RP1210A Adapter 
b. Click Volvo Trucks – Vehicle electronics ‘98 and select RP1210A Adapter 
c. Click Mack Trucks – V-MAC I/II/III, ITC and select RP1210A Adapter 
d. Click Volvo Trucks – V-MAC IV and select RP1210A Adapter 

6. Continue with installation. 

7.12.2. From Inside VCADS 

1. Start Program. 
2. Click the Tools menu and choose Options. 
3. Select the Comm. Unit Configuration tab. 
4. Select RP1210A Adapter and then select DPA 5 Dual CAN USB. 
5. Select USB for the Port. 
6. Select J1708 for the protocol. 
7. Go to the Comm. Unit Selection tab. 

a. Click Volvo Trucks – VERSION2 and select RP1210A Adapter 
b. Click Volvo Trucks – Vehicle electronics ‘98 and select RP1210A Adapter 
c. Click Mack Trucks – V-MAC I/II/III, ITC and select RP1210A Adapter 
d. Click Volvo Trucks – V-MAC IV and select RP1210A Adapter 

8. Click Ok. 
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7.13.   Volvo/Mack Premium Tech Tool (PTT) – Version 2.X 
 

1. Start Program. 
2. Select Settings from the PTT menu. 
3. Go to the Communication Unit tab: 
4. Highlight RP1210 Dearborn Group DPA 5 Single Application USB. 
5. Select Activate (green circle with checkmark).   
6. In a few seconds, under the Status column, Activated will appear next to RP1210 Dearborn Group DPA 5 Single Application USB. 
7. Select the OK Button. 

o Wait a few minutes to establish connection.   
o If connection doesn't occur, re-boot the PC.   
o Do not press Connect immediately after PTT opens! 

  Reading product data.... will appear after connection is established. 

7.14.   Volvo/Mack Premium Tech Tool (PTT) – Version 1.X 
1. Start Program. 
2. Select Settings from the PTT menu. 
3. Go to the Communication Unit configuration tab: 

a. It is here that you select the settings for each adapter that you may use.    For example, if you have an RP1210A adapter, it is here that you select 
which adapter, port, and protocol. 

b. NOTE:  This identifies the settings for each adapter.  It does not select which adapter the PTT application will use to communicate with the vehicle. 
4.  Go to the Comm unit selection tab: 

a. It is here that you identify which adapter is to be used by the PTT application to communicate with the vehicle.  You may have to change this selection 
depending upon the vehicle.   

b. For example, if you typically use an 88890020 adapter in direct mode, when you need to communicate with an older vehicle you will need to change to 
RP1210A adapter or the 9998555 adapters, depending upon the vehicle. 
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8.   Setting Up J2534-Compliant Applications 

Setting up and reflashing of a component using a J2534-compliant OEM application is a very lengthy process and is out of the scope of this manual.  For more information, 
you can refer to the OEM application documentation or you can download the OEM application reflashing guide from the Dearborn Group VSI-2534 device downloads 
page. 
 
In general, there will be a screen that will appear at some point that allows a user to select a J2534-compliant Vendor and Device for the reflashing event.  When you see 
this type of screen, choose Dearborn Group, Inc. and/or the DPA 5. 
 

 
 

The General Motors TIS2Web - J2534 Application Adapter Selection Screen 
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9.   Technical Support 

9.1. Technical Support 
After reading and following the troubleshooting procedures, please feel free to contact DG technical support.  For users in the United States, technical support is 
available from 9 a.m. to 5 p.m. Eastern Time.  You may also fax or e-mail your questions to us.  For prompt assistance, please include your voice telephone 
number.   

 
Users not residing in the United States should contact your local DG representative. 
 

 

DG Technologies Technical Support 
 
Phone:  (248) 888-2000 
Fax:  (248) 888-9977 
E-mail:  techsupp@dgtech.com  
Web site: www.dgtech.com  
 

 

mailto:techsupp@dgtech.com
http://www.dgtech.com/
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