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The DPA XL has a very robust set of features, capabilities and functions including cybersecurity 
enhancements by CyberTech from DG Technologies and is protected by CyberGuard inside.  It is 
also useful for vehicle ECU development, general design, hardware-in-the-loop simulation and 
anywhere bi-directional communications with a vehicle network are required. 
 
Permission is granted to copy any or all portions of this manual, provided that such copies are 
for use with DPA XL product and that “© 2023 DG Technologies.”, (herein referred to as 
“Dearborn Group”, “DG Technologies”, or “DG”), remains on all copies. 
 
The accompanying software, provided for use with the DPA XL, is also copyrighted. Permission is 
granted to copy this software for back-up purposes only. 
 
 

I M P O R T A N T 
To ensure your success with this product, it is essential that you read this document carefully 
before using the hardware. 
Damage caused by misuse of the hardware is not covered under product warranty. When using 
this manual, please remember the following: 
 
This manual may be changed, in whole or in part, without notice.  DG assumes no responsibility 
for any damage resulting from the use of this hardware or software.  Specifications presented 
herein are provided for illustration purposes only and may not accurately represent the latest 
revisions of hardware, software or cabling.  No license is granted, by implication or otherwise, 
for any patents or other rights of DG or of any third party. 

 
DG® logo is a registered trademark of DG Technologies, Inc. Other products that may be 
referenced in this manual are trademarks of their respective manufacturers. 
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1 Introduction 
How it works: The DPA XL is used to connect vehicle networks to personal computers (PCs).  
This allows programs written for the PC to retrieve pertinent information such as fault codes, 
component information, as well as perform bi-directional communications for component level 
diagnostics, tests, and component reprogramming.  
 
The DPA XL communicates with the PC using either a USB cable or via Bluetooth (Class I or Class 
II), and comes standard with the latest Technology and Maintenance Council (TMC) 
Recommended Practice (RP) RP1210-compliant drivers, as well as Society of Automotive 
Engineers (SAE) J2534-compliant drivers.   

1.1 Component Software Compatibility 
The adapter you have purchased is provided with the latest Technology and Maintenance 
Council (TMC) RP1210/SAE J2534 compliant interface and has been tested with the following 
OEM and component applications: 

 
❑ Allison DOC™ 

❑ Bendix® ACOM 

❑ Caterpillar® Electronic Technician 

❑ Cummins® Insite™  

❑ Cummins PowerSpec  

❑ Dana Diagnostic Tool™  

❑ Detroit Diesel Diagnostic Link™ 

❑ Detroit Diesel Reprogramming 

Station™ 

❑ Eaton ServiceRanger 

❑ Freightliner ServiceLink 

❑ GM GDS2 

❑ International® InTune 

❑ International® Master Diagnostics 

❑ International® NETS 

❑ International® Auto Upgrade (AU) 

❑ Isuzu IDSS II 

❑ Volvo Mack VCADS/PTT 

❑ Meritor-WABCO Toolbox 

❑ Navistar® Diamond Logic Builder  

❑ Navistar® HeRo 

❑ Navistar® NavKal 

❑ Navistar® NED 

❑ Navistar® ServiceMaxx 

❑ Paccar® Davie4 

❑ Vansco VMMS 

❑ ZF-Meritor TransSoft 

 
 

Any application claiming RP1210/J2534 compliance should work if the application and 
adapter both support the same protocol(s) and operating system(s). 
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1.2 Standards and Protocols Supported 
The adapter you have purchased provides more protocol and standards support than any other 
commercially available diagnostic adapter.   

   

❑ TMC RP1210 API 

❑ SAE J2534 API 

❑ SAE J1939 

❑ Single Wire CAN  

❑ Dual Wire CAN  

❑ CAN (ISO11898) 

❑ ISO15765  

❑ FT CAN  

❑ CAN FD  

❑ IESCAN - CAN@500k/J2284/GMLAN 

❑ SAE J1708 

❑ J1850 VPW (GM Class II) 

❑ J1850 PWM  

❑ ISO9141 

❑ ISO9141-2 

❑ ISO14230 

❑ GMLAN (HSCAN, SWCAN) 

❑ GMUART (SAE J2740) 

 

1.3 DPA XL Hardware Specifications  

Feature Data 

Dimensions 6.625 x 4.375 x 1.312 inches  

Voltage Requirements 9 – 32 Volts DC 

Current Requirements 250mA maximum through voltage range 

Operating Temperature Range -40 to +85C 

Wired PC Communications Type USB Version 1.1 or Higher 

Wired Connection USB Cable (up to 15 feet) 

Wireless Connection Bluetooth (DPA XL is equipped with Class 1 radio) 

Vehicle-Side Connector DB25 Female 

PC-Side Connector Standard B-Type USB Jack 

Auxiliary Power Jack 12 Volt DC 

PC Device Drivers TMC RP1210 Compliant Driver 
SAE J2534 and SAE J2534-2 Passthru Drivers 
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1.4 System Requirements  
We recommend a computer compatible with the latest version of the TMC RP1208 (PC 
Selection Guidelines for Service Tool Applications).  

 
Item 

 
Requirement 

PC IBM-Compatible 

Processor 1GHz or Faster 

RAM 4GB 

USB Port USB Version 1.1 or Higher 

Operating 
System 

Windows 10 & 11 (32-bit or 
64-bit) 

1.5 Standard Kit Configurations 
The DPA XL has the following standard kit (DG-400-10819 configurations:  

• DPA XL unit, DG P/N 450-DGT-1000812 

• DG 15 Foot USB Cable - DG P/N DG-15-1-USB-M-CABLE 

• VSI NxGen/DPA XL Freightliner-Cascadia J1939 cable, DG P/N DG-295-10836 

• Small Softcase (12x8x3), DG P/N SC1283 

Two other alternative kits are also available: 

• DPA XL Automotive Kit – DG P/N 400-10876 

• DPA XL W/6/9p Y Cable Kit – DG P/N – DG-400-10867 

There are limited uses for the 12V DC power jack.  It may be used for the following: 

o Benchtop programming 
o Usage with a SAE J1939 Breakout box 

WARNING 
The DPA XL should NOT be powered via the 12V DC power jack and DB-25  

(Deutsch or OBD-II cable) simultaneously. 
 

Connecting to multiple power sources may cause damage to the hardware. 

 

1.5.1 Powering the Hardware 

Once a power source has been connected, the POWER LED should light green.  Lights will first flash 
in a red, white, and blue sequence indicating that CyberGuard protection is enabled.  Depending on 
the vehicle, the key may need to be turned to turn the key to the on position before data link 
traffic and / or power is supplied through the diagnostic connector. 

1.5.2 Vehicle Network Connection 

The vehicle network connection can be made by using the supplied vehicle cable or by a custom 
cable to the hardware’s DB-25 (female) connector. 
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1.6 DPA XL Configuration Utility  

The DPA XL tool comes with support for many protocols (see Standards and Protocols 
Supported). The DPA XL Configuration Utility will tell you what protocols, API versions, and 
Product Version are supported. You can also use the DPA XL Configuration Utility to get the 
current firmware version.  Utility can be found in: 

Start ➔  DGTech DPA XL ➔ DPA XL Config Utility 

 
Figure 1 DPA XL Configuration Utility 

A Logging Configuration box will be listed with a number of selections. Select the Logging Type and Logging 
Method you are going to use.   Then select the OK button to confirm the selection.

 

Figure 2 DPA XL Configuration Utility – Select Logging Configuration 
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1.7 Setting Up Your Heavy-Duty OEM Diagnostic Applications 

1.7.1 Compliant Application 

The DPA XL works with all RP1210 compliant applications that support SAE J1708/J1587, 
CAN/SAE J1939/ISO15765, SAE J1850 VPW (GM Class II), ISO9141, ISO14230, SWCAN, FTCAN 
and SAE J1850 PWM protocols along with many others. This section shows how to configure 
the most common RP1210-compliant diagnostic applications to work with the DPA XL. 

1.7.2 General Setup for RP1210 OEM Application 

The following examples show how to select the DPA XL tool you will be using. Selecting an 
RP1210 adapter, commonly referred to as a Vehicle Datalink Adapter (VDA) varies widely from 
different OEM applications; however, the terminology remains similar.  The following table 
helps to introduce you to the terminology and helps you to make the correct selections the first 
time. 

You must set up every application (in their own individual way) to use the DPA XL.  
Not all OEM applications save the adapter configuration.  Some applications make the 
user select the adapter to be used every time the application is opened. 

 

 
If You See These Terms 

 
Select This 

Vendor 
API 
DLL 
Manufacturer 
Adapter Manufacturer 

 
DG Technologies DPA XL  
DGDPAXL 
 

Device Name 
Adapter Name 

The description of the tool can vary widely depending upon what part of 
the vendor ini file that the application is displaying. In general look for 
the tool name “DPA XL” that you will be using followed by the 
connection type you plan on using.  

• DPA XL, USB  

Device Number 
DeviceID 

 
1 = DPA XL 
 

Protocol  
(Depends on Application) 

Most Commonly Encountered: 

• SAE J1708 (SAE J1708/SAE J1587) 

• SAE J1939  

• ISO15765 

• CAN 
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1.7.3 Allison DOC 

NOTE:  Steps are for version 2020.1.0 (Build 08/21/2020); other versions vary slightly. 
1. Start program 
2. Click F4 - Connect 
3. Select the Correct Transmission Type 
4. Uncheck Smart Connect 
5. Click Connect 
6. Set Translator Device to DPA5 Multi-Application, USB 
7. Select protocol of SAE J1939, CAN, SAE J1708 or SAE J1850 
8. Click Advanced Setup 
9. Select Vendor of DGDPAXL 
10. Select Protocol of SAE J1939, CAN, SAE J1708 or SAE J1850 
11. Select Devise Name of DPA XL 
12. Device may be grayed-out on some selections 
13. Select Channel of Auto, 1, 2, 3, or 4.  Channel may not appear with some selections 
14. Click OK 

1.7.4 Bendix ACom Diagnostics 

NOTE:  Steps are for version 6.16; other versions vary slightly. 
1. Start program  
2. In Starter for ACom Diagnostics 6.16 window, click on PC/check mark/Truck icon located 

bottom, middle-right 
3. In Communications devise settings window [RP1210 tab] Available hardware interfaces 

– select DPA XL (DPA XL) 
4. Select green circle with check mark 
5. Highlight ECU (if known) and select Start with ECU 
6. If ECU not known, select Detect ECU 
7. Follow on-screen instructions 

1.7.5 Caterpillar Electronic Technician (CAT ET) 

1. Start Program 
2. Click Utilities ➔ Preferences ➔ Modify from the menu bar 
3. Click on Communications tab (it could already be selected) 
4. Select RP1210 Compliant Device 
5. Click Advanced 
6. Select Device Name 
7. Click OK 
8. Check Enable Dual Data Link Service 
9. Click OK 
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Additional CAT ET Configuration Notes: 

a. Enable Dual Data Link.  This checkbox should be checked in most cases.  However, 
on some older SAE J1708 (ATA) only vehicles, ET will not work with this checkbox 
checked.  If ET does not connect, try un-checking, or checking this button. 

b. The DPA product line does not support the CAT Data Link (CDL) protocol that is still 
common among certain CAT off-highway vehicles and industrial stationary 
equipment.  CDL is a proprietary protocol and there are no generic adapters on the 
market that support this protocol.   

o To find out if your vehicle/equipment is CDL or a standard protocol (SAE 
J1708/ATA, SAE J1939), you should look at the diagnostic connector for that 
equipment in the service manual. 

1.7.6 Cummins INSITE 

NOTE: Steps are for version 8.6.196 / DP; other versions vary slightly.  

PowerSpec Version 5.5 or newer is required to use the DPA XL.  Older versions of PowerSpec 
were not completely RP1210-compliant. 

1. Start Program 
2. Locate text box bottom, middle, click on down arrow 
3. Click on Add New… 
4. Click Next | RP1210 Adapters (Next)  
5. Select Vendor: 

a. DG Technologies DPA XL  
6. Select Adapter 

a. DPA XL  
7. Select Protocol: 

a. Auto Detect (or choose protocol for your engine) 
8. Click Datalink Adapter Connection Test (must be connected to data link), verify 

successful connection. 
9. Click OK | Next | Next | Save selection 

1.7.7 Detroit Diesel Diagnostic Link/Diagnostic Link  

NOTE: Steps are for version 8.12SP2; other versions vary slightly.   
 
There are several ways to select the adapter: 

1.7.7.1 From Inside DDDL 

1. From Desktop click on SID Configure icon 
2. Highlight DPA XL 
3. Select OK 
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1.7.7.2 Desktop Detroit Diesel Electronic Tool Suite 

1. Select Detroit Diesel Electronic Tool Suite icon from desktop. 
2. Select Configure  
3. Select DG DPA XL, select OK button 
4. Select Refresh  
5. Click on highlighted DDDL 7 or DDDL 6 item 

1.7.7.3 Diagnostic Link (version 6.50) Icon on Your Desktop 

1. Select Diagnostic Link icon from desktop 
2. Select Look at active and inactive faults 
3. To change the adapter, select Tools | Options | Interface 
4. Select Device Name from Local Communication Interface drop-down list. 
5. Select OK 

1.7.8 Dana Diagnostic Tool 

1. Start program 
2. Under Adapter Selection, choose DG Technologies DPA XL:  DPA XL  
3. Select Connect J1708 or Connect J1939 or Connect PLC as appropriate for your 

controller 

1.7.9 DDEC Reports 

1. Start program 
2. Select Tools | Set Connection interface | DPA XL 
3. Select OK 

1.7.10 Eaton ServiceRanger  

1. Start Program 
2. Click Go To tab  
3. Select Settings 
4. Under Communication Adapter choose DPA XL 
5. Under J1587 Connection choose DG DPA XL USB; Protocol=J1708; Speed=9600 
6. Under J1939 Connection choose DG DPA XL USB; Protocol=J1939; Channel=1; 

Speed=Auto 
7. If connecting via Bluetooth, Select the DG DPA XL # [Bluetooth ID] Bluetooth) for both 

the SAE J1708 and SAE J1939 device. 
8. Click Apply 
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1.7.11 Freightliner ServiceLink  

NOTE:  Including Cascadia Model – Dual CAN Channels Start program 
1. From the top menu bar, choose Admin 
2. Click on Show All Devices. 
3. Vendor  =  DG Technologies DPA XL  
4. J1708 Device =  Select Device Name 
5. J1939 Device =  Select Device Name 
6. CAN Device 
7. Click Configure 
8. Select Device Name 
9. Click Save Settings 

1.7.12 Meritor-WABCO Toolbox 

1. Start Program 
2. Select Utilities 
3. Select Adapter Selection 
4. Select Vendor: DG Technologies DPA XL  
5. Select Protocol: J1939 or J1708 
6. Select Adapter: DPA XL 
7. Select OK, then select X (top right) to close the Utilities Menu 
8. Select Toolbox 
9. Click System Setup; then select Adapter Selection 
10. Verify selections are correct, select OK 
11. Click on the Truck icon to start communication 

1.7.13 Volvo/Mack Software 

1.7.13.1 Volvo/Mack Premium Tech Tool (PPT) – Ver 2.X 

1. Start Program 
2. Select Settings from the PTT menu 
3. Go to the Communication Unit tab: 
4. Highlight DG Technologies DPA XL Application USB or DG Technologies DPA XL USB. 
5. Verify radio button in default column is selected 
6. Select Configuration… 
7. Click on Advanced Settings, then select the down arrow on the right side of the text box 
8. Highlight and click selection  
9. Select the OK button 
10. Verify DG DPA XL (SA) USB (or (MA) USB) is listed underneath Device Description:  
11. Select the OK button 

• Wait a few minutes to establish connection.  If connection doesn't occur, re-boot the 
PC.   

• Do not select Connect immediately after PTT opens.  Reading product data.... will 
appear after a little bit of time while the connection is being established. 
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1.7.13.2 Volvo/Mack Premium Tech Tool (PPT) – Ver 1.X 

1. Start Program 
2. Select Settings from the PTT menu 
3. Go to the Communication Unit configuration tab: 

• It is here that you select the settings for each adapter that you may use.    For 
example, if you have an RP1210A adapter, it is here that you select which adapter, 
port, and protocol. 

• NOTE:  This identifies the settings for each adapter.  It does not select which adapter 
the PTT application will use to communicate with the vehicle. 

4. Go to the Comm unit selection tab: 

• It is here that you identify which adapter is to be used by the PTT application to 
communicate with the vehicle.  You may have to change this selection depending 
upon the vehicle.   

• For example, if you typically use an 88890020 adapter in direct mode, when you 
need to communicate with an older vehicle you will need to change to RP1210A 
adapter or the 9998555 adapters, depending upon the vehicle. 

1.7.13.3 Volvo/Mack VCADS – From Initial VCADS Setup  

1. When prompted to configure a Communication Unit select RP1210A adapter 
2. When prompted for the adapter, select Device Name 
3. Select USB for the Port 
4. Select J1708 for the protocol 
5. When prompted for the Electrical Systems 

a. Click Volvo Trucks – VERSION2 and select RP1210A Adapter 
b. Click Volvo Trucks – Vehicle electronics ‘98 and select RP1210A Adapter 
c. Click Mack Trucks – V-MAC I/II/III, ITC and select RP1210A Adapter 
d. Click Volvo Trucks – V-MAC IV and select RP1210A Adapter 

6. Continue with installation 

1.7.13.4 Volvo/Mack VCADS – From Inside VCADS  

1. Start Program 
2. Click the Tools menu and choose Options 
3. Select the Comm. Unit Configuration tab 
4. Select RP1210A Adapter and then select Device Name 
5. Select the correct Port (USB or Bluetooth) 
6. Select J1708 for the protocol 
7. Go to the Comm. Unit Selection tab: 

a. Click Volvo Trucks – VERSION2 and select RP1210A Adapter 
b. Click Volvo Trucks – Vehicle electronics ‘98 and select RP1210A Adapter 
c. Click Mack Trucks – V-MAC I/II/III, ITC and select RP1210A Adapter 
d. Click Volvo Trucks – V-MAC IV and select RP1210A Adapter 

8. Click OK 
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1.7.14 Navistar/International Software 

1.7.14.1 International Truck and Engine – Master Diagnostics 

1. Start program 
2. Choose File ➔  MD Settings➔   COM Device ➔  Window with general VDA selection 
3. Select Dearborn Group DPA XL ➔ Window with specific port select your tools Device 

Name.  

1.7.14.2 Navistar Hydraulic ABS 

1. Start program 
2. Choose File ➔ Hydraulic ABS Settings ➔ COM Device ➔ Window with general VDA 

selection 
3. Select Dearborn Group DPA XL ➔ Window with specific port select your tools Device 

Name 

1.7.14.3 Navistar IPC 

1. Start program 
2. Choose File ➔ Settings ➔ COM Device ➔ Window with general VDA selection 
3. Select Dearborn Group DPA XL ➔ Window with specific port select your tools Device 

Name 

1.7.14.4 Service Assistant 

1. Start program 
2. Press third button from the top along the left side (has an icon that looks like a 

miniature interface cable) 
a. A window comes up that says Communication Device Selection and has two drop 

down boxes  
b. Select Dearborn Group DPA XL ➔  Select your tools Device Name 

1.7.14.5 Navistar Diamond Logic Builder (DLB) 

1. Select Diamond Logic Builder icon from desktop 
2. Enter username/password; select OK 
3. Choose Tools➔ Select Com Link ➔ Listing of adapters  
4. Select DG Technologies DPA XL ➔  DPA XL ➔ SAE J1939 protocol 
5. Choose Tools ➔ Active Com Link or select F6 
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1.7.14.6 Navistar NavKal 

1. Select NavKal icon from desktop 
2. Enter username and password (if required) 
3. Select Connection ➔ Select COM Link ➔ DG Technologies DPA XL ➔ DPA XL ➔ select 

J1708 or J1939 depending on engine type 
4. "Searching for Engine" appears 
5. Select engine type when prompted and click OK button 

1.7.14.7 Navistar HeRo 

1. Select HeRo icon from the desktop 
2. Enter username and password (if required) 
3. Select Connection ➔ Select COM Link ➔ DG Technologies DPA XL ➔ DPA XL ➔ select 

J1708 or J1939 depending on engine type 
4. Select Connect & Scan button 

1.7.14.8 Navistar Engine Diagnostics 

1. Select NED icon from the desktop 
2. Enter username and password (if required) 
3. Select Connection ➔ Select COM Link ➔ DG Technologies DPA XL ➔ DPA XL ➔ select 

J1939 
4. Select Connection | Activate Com Link or F6 if connection has not started 

1.7.14.9 Navistar ServiceMaxx J1939 or ServiceMaxx J1707 

1. Select ServiceMaxx icon from desktop 
2. Enter username and password (if required) 
3. Select Tools ➔ Select COM Link ➔ DG Technologies DPA XL ➔ select your tools Device 

Name ➔ select J1939 or J1708 depending on engine type. 
4. "Searching for Engine" appears 
5. Select engine type when prompted and click OK button 
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1.8 General Setup for J2534 OEM Application      
Setting up and reflashing of a component using a J2534-compliant OEM is out of the scope of 
this manual.  For more information, select  https://www.dgtech.com/oem-service-websites/ . 
In general, there will be a screen that will appear at some point that allows a user to select a 
J2534-compliant Vendor and Device for the reflashing event.  When you see this type of screen, 
choose DG Technologies and/or the DPA XL. 
 

 
Figure 3 Example of General Motors TIS2Web - J2534 Application VDA Selection Screen 
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2 Hardware Details    

The following figure shows the external features of the DPA XL: 
 

 
Figure 4 DPA XL Front & Side Views 

2.1 DB-25 
This is the connector where the 9 PIN Deutsch Cable (P/N DG-295-10811) or 16 PIN J1962 OBDII 
Cable (P/N 295-DGT-1000717) connects and powers the DPA XL from the vehicle connection.  

2.2 Auxiliary Power 
This is an external power port required for some older Hyundai/Kia vehicles and is provided per 
the SAE J2534 specification. 

2.3 USB 
USB cable connection.  Allows connection of the DPA XL to the PC. 

2.4 12V DC 
This is the external 12-volt Power Connector.  Not used when the 9 PIN Deutsch Cable (P/N DG-
295-10811) or 16 PIN J1962 OBDII Cable (P/N 295-DGT-1000717) is used. 

2.5 Status Indicators 

The DPA XL has three status LEDs that indicate activity of the following functions: 

• PC Connection – Indicates that the DPA XL has established a connection to the PC, and if 
the link is active. 

• Vehicle Connection – Indicates that the vehicle network connection is established / 
active. 

• Power – Indicates that the DPA XL is connected to a power supply (plug through a vehicle 
connection or by the USB cable), and whether the unit is operating properly. 
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• Cyberguard – Red, white and blue light sequence on power up indicates CyberGuard 
protection is enabled. 
 
DPA XL Back Label: 
 

 
 
 
 
 
 

LED Name LED State Description 

PC Connection Off 
PC has not initialized communication with DPA XL via 
the USB or Bluetooth data link. 

Vehicle Connection 

On Solid Red 
PC has initialized communication with DPA XL via the 
USB or Bluetooth data link. No bus activity. 

On Alternating 
Red / Green 

Communications activity on the PC DPA XL connection 
via USB or Bluetooth data link. 

Off 
No vehicle network protocol channel has been 
initialized for use. 

Power 

On Solid Yellow 
One or more vehicle network protocol channels have 
been initialized for use. No bus activity. 

On Alternating 
Yellow / Green 

There is activity on one or more vehicle network 
protocol channels. 

Yellow 
Unit not configured correctly.  Contact Customer 
Support 

Off No power supplied to the DPA XL unit. 

 
Bootloader 

Missing 

Power Light  
On Solid Green 

Unit is powered either via the vehicle connector or 
the external power jack. Unit is operating properly. 

Power Light 
On Solid Yellow 

Unit is powered either via the vehicle connector or the 
external power jack. Unit is not operating properly.  
Contact Technical Support. 

All LEDs Off 

If unit is properly powered up to a known, good power 
supply, the unit must be serviced.  Contact Customer 
Support. 

Bootloader 
New SW Image Needed 

All LEDs Blue 

A Firmware Update is needed. 

Bootloader Reflash in 
Progress 

All LEDs Blink 

A Firmware Update is running. 

Bootloader Manual Reboot 
Needed 

All LEDs Green 

The user must power cycle the unit.  This should not 
normally happen. 
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3 Software Download and Installation 
Only the Windows 10 & 11 operating system is supported by the DPA XL. 

The installation for the DPA XL includes files that are specific to this tool (found at 
https://www.dgtech.com/downloads/).  Most of the utility programs that DG distributes can be 
used by multiple DG tools and are distributed via DG Tech Utilities install, which is included with 
the DPA XL software installation. 

 

3.1 Software Requirements 
The following software requirements need to be met before the DPA XL software can be 
loaded: 

• Microsoft Visual C++ 2015 Update 3 Redistributable Package 

• Microsoft NET Framework 3.5 (Web download) 

• Microsoft NET Framework 4.5.2 Web 

• DG Tech Utilities 
 

3.2 Installing the DPA XL Software 

1. Download the latest install from https://www.dgtech.com/downloads/ 
2. Launch the installation program 

3. If required software is not present, a screen similar to the one below will be displayed.  
All required software installations must take place before the installation can be run.  
Please install required software by selecting Install. 

https://www.dgtech.com/downloads/


 

Page | 21  
 

 
Figure 5 Installation - Required Software Screen 

4. After all the software requirements have been met, the InstallShield Wizard for DGTech 
DPAXL will now be displayed. Click Next to continue.  Click Cancel to stop the 
installation. 

 

 

Figure 6 Installation - Welcome 

5. The suggested destination location is C:\DGTech\.  Click Next to continue.   
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Figure 7 Installation – Select Destination Folder 

 

6. After all files are installed, you can register your tool with DG. When the Product 
Registration Form displayed below is submitted, you will receive the latest product 
update information.  

 

       To register your tool your PC must have internet access and be connected to a DG    
       Technologies tool with power to complete the process.  Enter the information in the  
        form below and select the Register button.  

a. As an alternative to this you can call the number displayed on the screen to 
continue the process over the phone.         

 
Figure 8 Installation - Hardware Registration 

7. When installation is successful, click Finish.  
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Figure 9 Installation – Finish 

 

4 Hardware Connection to the PC 
 

 
 
The above image depicts typical connection to vehicle. 
 
IMPORTANT: the following sequence of connections must be followed, otherwise 
damage to vehicle or DPA XL may occur. 
 
You can use the Adapter Validation Tool software included in DGTech Utilities to troubleshoot 
communication problems. 
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4.1 Connect Cables to Tool 
Cable connections to the DPA XL are made secure more secure by thumb screws. This prevents 
unintentional disconnects to the hardware. 

4.2 Connect Tool to Computer 
Connect the DPA XL’s USB cable to the computer. If you are going to use a Bluetooth 
connection to the DPA XL do not connect the USB cable to the computer - Fig 1. 

4.3 Connect Tool to Vehicle 
Connect the DPA XL to the vehicle or module with the 9 PIN Deutsch Cable (P/N DG-295-10811) 
or 16 PIN J1962 OBDII Cable (P/N 295-DGT-1000717) – Fig 2.  

4.4 Power Warning 
In most instances power is supplied to the tool using the vehicle connector. You may have to 
turn the key on to enable power to this connector. The Power LED should be a solid Green if 
the unit is powered. Do not power unit from multiple sources. If power is being available via 
vehicle connector do not connect power to the 12V DC connector. 
 

5 Included Software Applications 

5.1 DG Update 
DG Update is an application that is installed with your DPA Tech Utilities.  It will run (by default) 
once every 30 days and will keep you up to date with the latest versions of drivers for all your 
DG Technologies products.  With this application running regularly, this will keep your DPA XL 
up-to-date with drivers and firmware.  DG Technologies recommends our customers keep up to 
date so that your OEM and component manufacturer diagnostic applications run smoothly. 
 

 
 

DO NOT DISCONNECT POWER FROM THE DPA XL DURING AN UPDATE!!! 
The utility will run once every 30 days as a user logs on.  This value is configurable, but defaults 
to 30 days.  It can also be invoked manually from the Windows Start Menu: 

Start ➔  DGTech Utilities ➔DG Update 
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5.1.1 DG Update – Internet Connection Required  

The DG Update utility depends on successfully connecting to the Internet (to one of DG’s 
servers) to retrieve the latest version information and to download the latest drivers and 
applications if necessary.   
 

Many companies install firewalls and virus protection and these may block the DG server 
queries and responses.  If you are connected to the Internet and have issues running DG 
Update (getting Unable to connect to the internet to check for updates messages), ensure that 
your firewall or virus protection will allow a connection to the Internet.  

5.1.2 DG Update – Main Update Screen 

The main screen appears like this.  Depending on which products are installed on your PC, the 
grid will display pertinent information about them.  When selecting DG Update from the 
Windows Start Menu, this is the first screen to appear. 

 

 
Figure 10 DG Update – Main Update Screen 

Connect your PC to the Internet and click the Refresh button.  Due to the nature of TCP/IP 
communications, errors connecting or sending/receiving of data are slow to appear, however 
the user will eventually be notified if there was a problem. 
 
If the check for updates was successful, the second column of the grid will display information 
returned from the DG server showing the most current versions. Should an install be out of 
date the color of the row will be red. 
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5.1.3 Successful Connect – Update Available 

In this case above, two of the products are out of date (Red), the user will be automatically 
presented with a prompt notifying them that there are updates available. Only if updates are 
available will the Download button and progress bar show up on the screen.  The progress bar 
will keep you informed of the download progress should you choose to download the latest 
drivers by clicking the Download button. 
When you click the Download button, you will be prompted to confirm starting of the 
download.  
 

 
Figure 11 DG Update - Out of Date Message 

 
Figure 12 DG Update - Prompt for Download  

Note:  The DG Update application can only download and install one item at a time.   
The user will be prompted for which ever one they want to update first. 

  
After choosing Yes, the program will download the drivers and update the progress bar while 
doing so.  Once the drivers have been downloaded, the application will unzip them and start 
the installation process.  The dialog box will go away after the install has been started. 
 

Do not disconnect your DPA or shut down computer until installation is complete. 
 
After the drivers have been downloaded (to the Windows temp directory – if you wish to save 
them for other machines), they will be unzipped and the program will exit right after starting 
the new driver installation.  Follow the installation instructions in the appropriate User Manual. 

5.1.4 Advanced Settings–Setting Default Time Check for Updates 

If you want to turn off, or alter the timeout period where the user is prompted to check for 
updates (the dialog below), press the Settings button. The advanced settings dialog box will be 
displayed.  To turn off the checking prompt, set the value to 0 (zero).  Otherwise, you can set 
the number of days between checks. 



 

Page | 27  
 

 
Figure 13 DG Update - Advanced Settings 

 

5.2 AVT Software 
If your OEM application is having trouble communicating with the Diagnostic Tool, you can use 
the Adapter Validation Tool (AVT) to help troubleshoot this problem.  AVT allows you to 
determine: 

• If your drivers are installed correctly. 

• If a connection to your tool can be made, 

• Detection of data link activity. 

• Please check that the OEM application is configured to use the selected Diagnostic Tool, 
and the correct protocol is selected. 

 

5.2.1 AVT Startup 

Click AVT on the desktop or from the start menu and a screen will be displayed with two 
different AVT versions to choose from.  

 
Figure 14 - AVT Startup 

• Click on the MD/HD truck selection if you are connecting to a heavy duty or medium 
duty vehicle.  The data bus protocols most often found on these vehicles include J1939, 
ISO15765 and J1708/J1587.  
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• Click on the OBDII car selection if are connecting to a light or medium-duty vehicles. The 
data bus protocols most often found on these vehicles include CAN/ISO15765, J1850, 
ISO9141, and ISO14230.   

 

  
J1708 Connector (6-pin Deutsch) J1939 Connector (9-pin Deutsch) 

This connector only has  
the J1708/J1587 protocol. 

OEMs switched to this connector when they 
moved to J1939.  J1708 may not be 

available. 

 
 
 

 
J1962 Connector 

Most often found in light or medium duty vehicles. 
Some heavy-duty vehicles also use this connector. 

 

 

Figure 15 - Vehicle Diagnostic Connectors 
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5.2.2 AVT MD/HD Application 

 
Figure 16 AVT HD - Main Screen 

1. Connect the tool you want to test to the vehicle 
2. Select the Vendor and Device you want to test the connection to 
3. Then click the Test Connections selection.   
4. Depending on the results of the test, both the RP1210 Status Window Message will turn 

Green (pass) or Red (fail). 
a. If the Status Window turns Red, there is a problem causing the PC to not 

communicate with the Diagnostic Tool. Disconnect the Diagnostic Tool from the 
vehicle and PC; then reconnect them, this time connecting to another USB port 
on the PC. 

b. If the Status Window turns Green and data message window turns Red, then the 
PC is connecting to the Diagnostic Tool, but not receiving messages. Check the 
vehicle ignition switch and vehicle to adapter cabling.  Disconnect the Diagnostic 
Tool from the vehicle and PC; then reconnect them. 

Refer to the chapter on how to configure your OEM application to use the Diagnostic Tool. 
Read the Test Results Discussion and Next Steps screen carefully and follow those directions to 
help diagnose where the issue may be.  If, after reading and following the instructions and you 
cannot get the Diagnostic Tool working, please contact DG technical support. 
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5.2.2.1 Good Connection (PC to Diagnostics Tool), Good Read of Data 
(Diagnostic Tool to Vehicle) – Green/Green 

The screen snapshot below shows the PC successfully connecting to the Diagnostic Tool 
(RP1210 Status Window). Green in the Status window indicates a good connection to the tool.  
The Protocol Status bars indicate success/fail for each protocol that is scanned by default.  If the 
status bar is green, then data was detected, and the corresponding baud rate is displayed. 
 

 
Figure 17 AVT HD - Green / Green 

5.2.2.2 Good Connection (PC to Diagnostics Tool), Not Able to Read Data 
(Diagnostic Tool to Vehicle) – Green/Orange 

The data buses are automatically scanned.  The above screen snapshots show the PC 
successfully connecting to the Diagnostic Tool, but AVT was not able to read bus data.  No data 
was read from CAN Channel 2 or 4.  An Orange result on CAN Channel 3 indicates the Diagnostic 
Tool is connected, do no data was detected. 
 

 
Figure 18 - AVT HD - Green / Orange 

5.2.2.3 Not Seeing Diagnostic Tool Device in VDA Selection List – Red/Red 

The screen snapshot below shows the PC not connecting to the Diagnostic Tool. A red result 
indicates a bad Diagnostic Tool connection and the software is unable to read data.  The test 
has failed.  Follow directions on Test Results Discussion and Troubleshooting Steps screen and 
run test again. 
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Figure 19 AVT HD - Red / Red 

5.2.2.3.1 AVT HD Results 

If you have installed the Diagnostic Tool drivers and can get AVT to a Green/Green outcome, 
you should be able to configure your diagnostic application to use the Diagnostic Tool.  If your 
diagnostic application does not display in the VDA selection dialog box, this could indicate one 
of three things:   
 

1. The application is not compliant and does not work with the Diagnostic Tool. 
a. Some applications require a specific, proprietary adapter. 

2. Application is compliant, but Diagnostic Tool does not support the protocol needed. 
3. Problem with the main INI file. 

a. Some VDAs create issues with the INI file when they install/uninstall.  
b. Many OEM diagnostic applications are aware of this issue and can read through 

the errors. 

5.2.2.4 AVT HD Fix RP121032.INI File 

When the AVT software is launched, you will be told if a problem exists in the main INI file.  If 
you wish to fix this issue, which we highly recommended, press the Fix RP121032.ini File button 
on the main screen. The following is the dialog box that will appear when AVT is launched and a 
problem is found in the main INI file. 

 
Figure 20 AVT HD - Fix INI Message Box 

When you choose the Fix RP121032.INI File button, AVT will bring up a separate program called 
Fix INI that will allow you to view and fix the INI file if there are errors detected.   
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In the example below, a bad INI file was detected (depicted by a yellow background). Click the 
Make Changes button and the INI file problem will be corrected.   

 

 
Figure 21  Fix INI - Make Changes 

5.2.2.5 Advanced Testing Dialog (Vendor/Device/Protocol) 

Should you need to scan other protocols to see if they are present, you can do so by using the 
Advanced Testing Interface.  This allows you to choose baud rate and channel that a 
Vender/Tool supports.  This option is mainly used for engineering purposes and requires some 
knowledge of the vehicle’s diagnostic link setup.  
 

 
Figure 22 AVT HD - Advance Test 
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5.2.2.5.1 Baud Rate Drop Down List Box 

The Baud Rate drop down list box allows the user to select one of the supported protocol 
speeds for the selected protocol.  The entries in this list box come from the VDA vendor’s INI 
file.  Click the Use Baud Rate checkbox to activate a “Protocol: Baud=XXX” connection. If both 
the Use Baud Rate and Use Channel checkboxes are checked, then AVT will initiate a “Protocol: 
Baud=XXX; Channel=X” connection. 

5.2.2.5.2 Channel Drop Down List Box 

The Channel drop down list box allows the user to select one of the supported channels for the 
selected device.  The entries in this list box come from the VDA vendor’s INI file.  Click the Use 
Channel checkbox to activate a “Protocol: Channel=X” connection.  If both the Use Baud Rate 
and Use Channel checkboxes are checked, then AVT will initiate a “Protocol: Baud=XXX; 
Channel=X” connection.  

5.2.2.5.3 Vender Supports CAN Auto Baud Checkbox 

This checkbox indicates whether the API supports CAN (CAN, J1939, ISO15765) automatic baud 
detection.  Even though this variable may be set to TRUE, the next four fields indicate whether 
the API supports Baud=XXX connect formats for CAN, J1939, and ISO15765. This field is just an 
informational field, and not all VDA vendors will support this feature. 

5.2.2.5.4 Protocols Supporting Baud-XXX 

These checkboxes indicate whether the API supports setting a specific baud rate (or automatic 
baud detection) for a specific protocol. These entries come from the VDA vendor’s INI file.  
These fields are just for informational purposes.  Not all VDA vendors will support this feature. 

5.2.2.5.5 Advanced Testing Commands 

When using this dialog box to initiate an advanced test, there is no error checking done to 
prevent the user from initiating a “Baud=XXX” or “Channel=X” connection to a VDA even if the 
vendor does not support that connection format.    
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5.3 DPA XL Firmware Update 
 

 
 

Figure 23 DPA XL Firmware Updater  

5.3.1 Launch the DPA XL Firmware Update Programs Manually 

1. Stop all applications that are using the DPA XL (if any) 
2. Start the DPA XL Firmware Update program 

Start ➔ DGTech DPA XL ➔ DPA XL Firmware Update 
3. Choose Select Firmware File to proceed 

 
       Figure 24 DPA XL Firmware Update - Success 

 

 
    Figure 25  DPA XL Firmware Update – Failure 

 

 

4. Select the correct firmware file (the latest version is already selected by default).   
5. Firmware files are in separate sub-directories under the Utilities directory where the 

DPA XL drivers are installed, typically: 
C:\ DGTech\DPAXL\Reflash 

6. Click on the Update Device button, if you want to update the firmware in your DPA XL. 
 

DO NOT DISCONNECT POWER FROM THE DPA XL DURING A FIRMWARE UPDATE!!!   
ALLOW THE UPDATE TO FINISH! 



 

Page | 35  
 

Appendix A. Technical Support and Return Merchandise 
 

Technical Support  
After reading and following the troubleshooting and validation procedures in this document 
please check the FAQ page at www.dgtech.com/faqs/. If you are still not able to resolve an 
issue, please feel free to contact DG technical support.  For users in the United States, technical 
support is available from 9 a.m. to 5 p.m. Eastern Time.  You may also fax or e-mail your 
questions to us.  For prompt assistance, please include your voice telephone number and the 
serial number. 

 

Users not residing in the United States should contact your local DG 
representative or e-mail techsupp@dgtech.com 

 
Return Merchandise Authorization (RMA) 
If technical support has deemed that there may be a physical problem with your DPA XL, you 
will be issued an RMA number.  You would then return the product along with any 
documentation of ownership you have (proof of purchase/price) to the following address: 

  
Product Repair Services  
Attn:  RMA# xxxxxxx 
DG Technologies 
33604 West 8 Mile Road 
Farmington Hills, MI  48335 

 
 
 
 

 

DG Technologies Technical Support 
 
Phone: 1-248-888-2000 
Fax: 1-248-888-9977 
E-mail: techsupp@dgtech.com  
Website:www.dgtech.com/tech-support 
 

http://www.dgtech.com/faqs/
mailto:techsupp@dgtech.com
mailto:techsupp@dgtech.com
http://www.dgtech.com/tech-support
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Appendix B. Warranty Information and Limitation 
Statements 

 
Warranty Information 
DG Technologies, Inc. the DPA XL is warranted against defects in materials and workmanship for 
two (2) years following date of shipment.  Cables (both USB and vehicle) are warranted for 90 
days.   
 
DG Technologies will, at its option, repair or replace, at no cost to the customer, products which 
prove to be defective during the warranty period, provided the defect or failure is not due to 
misuse, abuse, or alteration of the product.  The customer is responsible for shipment of the 
defective product to DG. This warranty does not cover damage to any item that DG 
Technologies, determines has been damaged by the customer's abuse, misuse, negligence, 
improper assembly, modification, or operation of the product.  
 
A Return Merchandise Authorization (RMA) number must be issued to the customer by our 
Technical Support Department at 1-248-888-2000 and must be included with the product being 
returned (for more details, see section Return Merchandise Authorization (RMA)).  A DPA XL is 
warranted for 90 days after a warranty repair, or to end of the original factory warranty period, 
whichever is longer.  
 

Limitation Statements 
 

General Limitation and Risk Assignment 
To the maximum extent permitted by applicable law, DG Technologies and its suppliers provide 
support services on an “as-is” basis and disclaim all other warranties and conditions not 
specifically stated herein, whether express, implied or statutory, including, but not limited to, 
any warranties of merchantability or fitness for a particular purpose, lack of viruses, accuracy or 
completeness of responses, results, lack of negligence or lack of workmanlike effort, and 
correspondence to description. The user assumes the entire risk arising out of the use or 
performance of the device, its operating system components, and any support services. 
 
Exclusion of Incidental, Consequential, and Certain Other Damages 
To the maximum extent permitted by applicable law, in no event shall DG Technologies or its 
suppliers be liable for any special, incidental, indirect or consequential damages whatsoever, 
including but not limited to: damages for loss of profit, loss of confidential or other information; 
business interruption; personal injury; loss of privacy, failure to meet any duty (including good 
faith or of reasonable care); negligence; and any other pecuniary or other loss related to the 
use of or the inability to use the device, components or support services or the provision of or 
failure to provide support services or otherwise in connection with any provision, even if DG 
Technologies or any supplier has been advised of the possibility of such damages. 
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Limitation of Liability and Remedies 
Notwithstanding any damages that you might incur for any reason whatsoever (including, 
without limitation, all damages referenced above and all direct or general damages), in no 
event shall the liability of DG Technologies and any of its suppliers exceed the price paid for the 
device. The user assumes the entire risk and liability from the use of this device. 
 
Right to Revise or Update Without Notice 
DG Technologies reserves the right to revise or update its products, software and/or any or all 
documentation without obligation to notify any individual or entity. 
 
Governance 
The user agrees to be governed by the laws of the State of Michigan, USA, and consents to the 
jurisdiction of the state court of Michigan in all disputes arising out of or relating to the use of 
this device. 
 
Contact Information 
Please direct all inquiries to:  

DG Technologies 
33604 West 8 Mile Road 
Farmington Hills, MI  48335 
Phone 1-248-888-2000 
Fax 1-248-888-9977 

Appendix C. FCC and Certification Industry Canada 
The DPA XL has been tested and found to comply with the limits for a Class B digital device, 
pursuant to Part 15 of the FCC Rules (see the back of the DPA XL for FCC and IC specific 
identifications).  These limits are designed to provide reasonable protection against harmful 
interference in a residential installation. The DPA XL uses and generates radio frequency 
energy.  If not installed and used in accordance with the instructions, it may cause harmful 
interference to radio communications. If the DPA XL does cause harmful interference to radio 
or television reception, which can be determined by turning the affected equipment off and on, 
the user is encouraged to try to correct the interference by one or more of the following 
measures: 

• Reorient or relocate the receiving and/or sending antennas. 

• Increase the separation between the DPA XL and the affected receiving equipment. 

• Connect the equipment into an outlet on a circuit different from that to which the 
receiver is connected.  

• Consult the dealer or an experienced radio/TV technician for help. 
 
This product complies with FCC OET Bulletin 65 radiation exposure limits set forth for an 
uncontrolled environment. 
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Industry Canada 
Operation of the DPA XL is subject to the following two conditions:  

1. This device may not cause harmful interference, and  
2. This device must accept any interference received, including interference 

that may cause undesired operation. 
 

Changes not expressly approved by DG Technologies, Inc. to the DPA XL could void the user's 
authority to operate the DPA XL.  The following is a sample rear label from the DPA XL depicting 
the FCC and IC identifiers. 

 

 
Figure 26 Bluetooth Label 

 

The following are the DPA XL Bluetooth details as required to be published by the FCC. 
 

Operating Frequency 2.4GHz 

Power Output Maximum < 4.4dBi 

Contains Transmitter Module FCC ID:  QOQWT11u 

Transmitter Bluetooth QDID B012647 
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Appendix D. List of Acronyms Used in Document 
 
Acronym 

 
Description 

API Application Programming Interface 

CAN Controller Area Network  

CAN FD Controller Area Network Flexible Data 

DG DG Technologies 

DoIP Diagnostics over IP 

DPDU API Diagnostic Protocol Data Application Programming Interface 

DW CAN Dual Wire Controller Area Network 

Class2 GM’s implementation of SAE J1850 Protocol 

ECU Electronic Control Unit.   

FTCAN Fault Tolerant Controller Area Network 

FW Firmware 

ID Identification 

ISO International Standards Organization 

ISO14230 Keyword protocol running over UART 

ISO9141 Serial Communication Protocol implemented in Ford & CARB 

J2534 SAE Specification for Legislated Reprogramming Support 

LED Light Emitting Diode 

KWP Keyword Protocol 

KWP2000 Keyword Protocol 2000 (ISO 14230) 

OBD On Board Diagnostics 

OEM Original Equipment Manufacturer 

PC Personal Computer 

PWM Pulse Width Modulation, used in Ford’s implementation of J1850 

RP1210 TMC recommended practice Windows Application Programming Interface (API) 

RAM Random Access Memory 

SAE Society of Automotive Engineers 

SCI DCX’s proprietary UART based protocol 

SCP Standard Corporate Protocol, Ford’s implementation of J1850 (J1850 PWM) 

STG Short to Ground 

SWCAN Single Wire Controller Area Network 

TMC Technology and Maintenance Council 

UAC User Account Control 

USB Universal Serial Bus 

VBAT Vehicle Battery 

VDA Vehicle Datalink Adapter 

VNI Vehicle Network Interface 

VPW Variable Pulse Width Modulation used in GM implementation of J1850 

 

http://encyclopedia2.thefreedictionary.com/Controller+Area+Network

